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1 How to draw in perspective with Illustrator  Illustrator Guide

How to draw in perspective with Illustrator
In Adobe Illustrator, you can easily draw or render artwork in perspective by using a feature set that 
works on established laws of perspective drawing. When you draw in perspective, you can represent 
on a flat surface a three-dimensional scene as it is naturally perceived (by the human eye). For 
example, a road or a pair of railway tracks can seem to meet or vanish in the line of vision.

About the Perspective Grid tool

The Perspective Grid tool group consists of the Perspective Grid tool (Figure 1) and the Perspective Selection tool. The 
perspective tools in Illustrator help you to draw in perspective by:

• Defining or edit one, two, and three vanishing point perspectives in a document.
• Controling different perspective-defining parameters interactively.
• Creating objects directly in perspective.
• Bringing existing objects into perspective.
• Transforming objects in perspective (move, scale, and move objects in a perpendicular direction).
• Drawing objects with real-world measurement in perspective. 

Figure 1 Perspective grid illustrating two-point perspective

Plane Switching Widget

Left vanishing 
point

Right vanishing 
point

Horizon line

Extent of grid

Plane controls Origin Ground level



2How to draw in perspective with Illustrator  Illustrator Guide© 2018 Adobe Systems Incorporated. 
This document requires Adobe Illustrator CC 2018. Technical instructions may differ depending on your version.

When the Perspective Grid tool is selected, it shows a perspective grid with the following elements:

• Left and right grid controls to adjust planes
• Horizon height
• Left and right vertical plane position
• Visibility and extent of a grid cell
• Grid cell size
• Origin
• Left and right ground-level points used for grid movement

In the perspective grid, use the Plane Switching Widget (Figure 2) to select the active perspective plane.

You can set options to position the widget and choose to display it when the perspective grid is visible. To set these 
options, double-click the Perspective Grid tool in the Tools panel. In the Perspective Grid Options dialog box, you can 
select the following:

• Show Active Plane Widget: This option is selected by default. If you deselect this option, the widget is not 
displayed with the perspective grid.

• Widget Position: You can choose to display the widget on the Top-Left, Top-Right, Bottom-Left, or Bottom-
Right corner of the screen.

When you select the Perspective Selection tool, the left, right, and horizontal plane controls are displayed. You can 
switch to the Perspective Selection tool by pressing Shift+V or selecting it from the Tools panel. Use the Perspective 
Selection tool to do any of the following tasks:

• Bring objects, text, and symbols into perspective with respect to the active plane

• Switch active planes by using keyboard shortcuts

• Move objects into perspective (parallel to the active plane)

• Move objects perpendicular to the active plane

With the Perspective Selection tool, the active planes in the perspective grid are indicated by pointers.

This guide presents the basics of the Perspective Grid tool and the Perspective Selection tool. For more detailed 
information about how to use the perspective grid, see “Perspective drawing” in Illustrator Help.

Figure 2 Plane Switching Widget
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Perspective grid presets
Illustrator provides presets for one-point, two-point, and three-point perspectives (Figure 3).

To select a perspective grid preset:

1. Click View > Perspective Grid.

2. Select one of the presets (One Point Perspective, Two Point Perspective, or Three Point Perspective) and then 
select Normal View (Figure 4).

The chosen perspective grid appears in the document window (Figure 1).

Figure 3 Perspective grid presets

Figure 4 Perspective Grid options in the View menu
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Working with objects and text in perspective

You can use the perspective grid to create and manipulate objects and text in perspective.

Drawing new objects in perspective
To draw objects in perspective, use the line group tools or rectangle group tools while the grid is visible.

To draw new objects in the grid:

1. To select the plane in which you want to draw an 
object, click one of the faces of the cube in the Per-
spective Grid Widget (Figure 6).

The plane you selected becomes the active plane.

2. Choose the Rectangle Tool in the Tools panel  
(Figure 5).

Note: You can use any shape tool with the perspective 
grid except the Flare tool.

3. Choose fill and stroke colors in the Control panel.

4. Drag anywhere in the document window (Figure 6). The 
shape automatically aligns with the active plane.

Figure 5 Shape tools in the Tools panel

Figure 6 Drawing a rectangle in the perspective grid
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5. To reposition the shape in the perspective grid, hold 
down Ctrl (Windows) or Command (Mac OS).

This temporarily selects the Perspective Selection 
Tool.

6. Drag the shape to a new location in the document 
window (Figure 7).

As you drag, position coordinates help you align the 
object in the perspective grid.

7. Release the mouse button to accept the change. The 
shape is repositioned.

Attaching objects to perspective
If you have already created objects, Illustrator provides the option to attach objects to an active plane in the grid.

To attach an object to the grid:

1. Select No Active Grid in the Plane Switching Widget 
(Figure 8).

2. Choose the Rounded Rectangle tool in the Tools 
panel (Figure 5) and set the fill and stroke for the 
object in the Control panel.

3. Drag to draw a rounded rectangle anywhere in the 
document window.

Observe that the rectangle is not drawn in 
perspective. That happens because in step 1 you chose 
to have no active plane in the perspective grid.

4. Select the Left, Right, or Horizontal Grid in the Plane 
Switching Widget.

Your selection becomes the active plane.

5. Choose the Perspective Selection Tool in the Tools panel (Figure 9).

6. Click to select the rounded rectangle you drew in the document window.

Figure 7 Repositioning an object in the perspective grid

Figure 8 Plane Switching Widget

Figure 9 Perspective Grid tools in the Tools panel
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7. Choose Object > Perspective > Attach To Active Plane.

The object’s bounding box is aligned with the active plane (Figure 10).

Note: Using the Attach To Active Plane command does not affect the appearance of the object.

8. Drag the selection to a new location in the document window and observe the change in perspective of the object 
relative to the selected plane (Figure 11).

Figure 10 Object’s bounding box aligned to the perspective grid

Figure 11 Dragging the object in the perspective grid
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9. If you want to release an object with a perspective view, select Object > Perspective > Release With Perspective. 
The selected object is released from the associated perspective plane and is available as a normal artwork.

Note: Using the Release With Perspective command does not affect the appearance of the object.

Moving objects in perspective
To move an object in perspective, select the Perspective Selection tool (Shift+V) and then either use the arrow keys or 
drag the object. To constrain the movement in perspective, Shift-drag the object.

You can also move objects perpendicular to the plane in which they are drawn. This is useful when creating parallel 
objects, such as the walls of a room.

To move an object perpendicular to the plane in which it is drawn:

1. Select the object by using the Perspective Selection Tool.

2. Holding down the tilde (~) key, drag the object to the required position.

This action moves the object perpendicular to the plane in which it is drawn (Figure 12).

Scaling objects in perspective
You can scale objects in perspective by using the Perspective Selection tool. While scaling objects in perspective, the 
following rules apply:

• Scaling is done in the object’s plane. When you scale an object, the height or distance is scaled based on the 
object’s plane and not the active plane.

• In case of multiple objects, scaling is done for objects that are on the same plane. For example, if you select 
multiple objects on the right and left plane, scaling occurs for all of the objects that are on the same plane as 
the object whose bounding box is used for scaling.

• Objects that have been moved perpendicularly are scaled on their respective planes and not the current or 
active plane.

Figure 12 Moving a rectangle perpendicular to the plane in which it is drawn
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To scale objects in the grid:

1. Choose the Perspective Selection Tool in the Tools 
panel.

2. Select an anchor point of the shape.

As you hover over an anchor point, the pointer 
changes to a solid square inside a dashed square. 
Corner anchor points display X and Y coordinates 
(Figure 13).

3. Drag the anchor point to scale the object.

4. To scale the shape proportionally, Shift-drag an anchor 
point (Figure 14).

Note: Only the grid in the object’s plane is visible as you Shift-drag the anchor point.

Adding text and symbols in perspective
You cannot directly add text and symbols to a perspective plane when the grid is visible. However, you can bring text 
or symbols into perspective after creating them in normal mode.

To bring text or symbols in perspective:

1. Select the Type Tool or the Vertical Type Tool  
(Figure 15).

The pointer changes to an I-beam within a dotted box. 
The small horizontal line near the bottom of the 
I-beam marks the position of the baseline, on which 
the text rests.

2. (Optional) Set text-formatting options in the Control 
panel, Character panel, or Paragraph panel.

3. Click where you want the line of text to begin.

4. Enter the text. Press Enter (Windows) or Return (Mac OS) to begin a new line of text within the same type object.

Figure 13 Selecting an anchor point

Figure 14 Scaling an object in the perspective grid

Figure 15 Text tool options
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5. When you finish entering text, select the Perspective 
Selection Tool, and then select the type object.

6. Drag the existing text or symbol to the required 
position.

The text object’s bounding box is aligned with the 
active plane (Figure 16).

7. Release the mouse button to place the text in the 
perspective grid (Figure 17).

8. (Optional) Double-click the text object to edit text in 
isolation mode (Figure 18).

The Edit Text option is available in the Control panel 
(Figure 19) and under the Object > Perspective 
menu.

Exit isolation mode by clicking the Exit Isolated Group 
button at the upper-left corner of the artboard.

Note: The options in the Control panel change to Edit 
Symbol or Edit Text, depending on which you are 
doing.

Figure 16 Dragging object to the perspective grid

Figure 17 Text placed in the perspective grid

Figure 18 Editing text in isolation mode

Figure 19 Control panel with Edit Text options
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Perspective grid settings

You can configure the perspective grid settings from the View > Perspective Grid menu (Figure 20).

The options available in the perspective grid settings include the following:

• Show Rulers: This option shows the ruler division only along the true height line. To view the rulers in the 
perspective grid, choose View > Perspective Grid > Show Rulers.

• Snap to Grid: This option allows snapping to gridlines while bringing in perspective, moving, scaling, and 
drawing in perspective.

• Lock Grid: This option restricts the grid movement and other grid editing when you’re using the Perspective 
Grid tool. Only the visibility and the plane position can be changed.

• Lock Station Point: When the Lock Station Point option is checked, the vanishing points move in sync. If not 
checked, the vanishing points move independently and the station point also moves.

Figure 20 Perspective Grid options in the View menu

https://edex.adobe.com/
https://creativecommons.org/licenses/by-nc-sa/3.0/
https://creativecommons.org/licenses/by-nc-sa/3.0/

	How to draw in perspective with Illustrator
	About the Perspective Grid tool 
	Perspective grid presets 

	Working with objects and text in perspective 
	Drawing new objects in perspective 
	Attaching objects to perspective 
	Moving objects in perspective 
	Scaling objects in perspective 
	Adding text and symbols in perspective 

	Perspective grid settings 


